Best Running Tips

JavascriptLOGO This is a JavaScript-reliant Site, so you will need to have JavaScript "enabled" in your Browser. If you don't have it "enabled", you can do so with the help of instructions specific to your Browser at EnablingJavaScript.

BroadbandLOGO
InternetExplorerLOGO
JavaLOGO
This Website runs best with:
  1. a Broadband connection,
  2. using a Safari (Version 13.0.2 ) or a Mozilla-Firefox (69.0.3(64-Bit)) Browser,
  3. with Java SE Runtime Environment Version 8 Update 201 installed.
*Requirements in the 2nd & 3rd can be obtained via left-clicking on Safari or Mozilla Firefox and JavaSoftware respectively.

AdobeLOGO For now**, you will also need to install Adobe Flash Player via this link Flash Player, where you'll find a chart to help you pick the version most suited to your Operating System/Platform and Browser.

**I am fervently updating this entire Site to 'HTML5', incoporating its <audio> and <video> tags. So this won't be necessary in the future!

 ℳ Last-Updated: 2019.10.13

© All Contents Copyright 1952-  Martin Eden